• Sign Up! To view all forums and unlock additional cool features

    Welcome to the #1 Explorer ST Forum and Explorer ST community dedicated to Explorer ST owners and enthusiasts. Register for an account, it's free and it's easy, so don't hesitate to join the Explorer ST Forum today!

Anyone smarter than my dealer? Help?

DLip

New Member
Messages
2
Reactions
0
Location
West Chester, PA, USA
#1
Have 3000 miles on my 2020 Explorer ST. Last week all of a sudden loud, pulsing sound coming out of back right speaker whether car on or off. Took them a week and a half to discuss with Detroit and eventually I got it back with new audio module...now stereo sounds shitty like no bass and piped in engine sound gone. I know many say it sounds cheesy but I frankly liked the sound in Sport as I don’t wanna change exhaust and mess with extended warranty. So anyone here have thoughts? Dealer says they have no clue what is causing it-I question whether they changed audio module or just disconnected that rear speaker as they said they were considering doing when I first brought vehicle in. Any help appreciated....
 

UNBROKEN

Active Member
Messages
745
Reactions
677
Location
Houston, TX, USA
#2
I mean...have you listened to see if that speaker is still playing? Or that all of them are still playing?
 
Messages
26
Reactions
7
Location
Baldwin Harbor, NY, USA
#5
Your receipt from the dealer should have the part number of the module they changed. If it wasn't charged to the job then it probably wasn't changed. Even though it was no charge to you, someone has to pay for it.

If it was charged out to the repair and wasn't installed then don't lose that receipt. Now you have more ammo once you get to the bottom of this.
 


Top