• Sign Up! To view all forums and unlock additional cool features

    Welcome to the #1 Explorer ST Forum and Explorer ST community dedicated to Explorer ST owners and enthusiasts. Register for an account, it's free and it's easy, so don't hesitate to join the Explorer ST Forum today!

Who's experienced issues with Buggy Screens?

Who's experienced issues with Buggy Screens?

  • Yes

    Votes: 6 54.5%
  • No

    Votes: 2 18.2%
  • Sometimes

    Votes: 3 27.3%

  • Total voters
    11
Messages
102
Reactions
46
Location
The Woodlands, TX, USA
#1
Evidently Ford shipped out Explorers with buggy screens from the Chicago plant. Read below.

Oct. 2 that the Chicago plant had started shipping Explorers directly to dealers. But most of those models also have required repairs before they can be sold, said the people, who asked not to be identified describing internal issues the company is having.

And not all problems with Chicago-built SUVs are being fixed before they reach customers’ driveways. Consumer Reports had problems with the Lincoln Aviator -- a mechanically similar model built alongside the Explorer -- that the magazine’s testers purchased last month for $63,400. The digital gauges that display speed, fuel consumption and other important information shake and flip, making them difficult to read.

“Ford does tend to struggle with the new introductions, especially if they’re a larger departure from the previous design,” said Jake Fisher, the magazine’s director of auto testing. “It could take a few years to get the bugs worked out.”

Ford is not experiencing similar setbacks as it begins building a redesigned version of its Escape compact SUV at its factory in Louisville, Kentucky. LaNeve told analysts the Escape “is a much more normal launch.”
 

Jules

New Member
Messages
12
Reactions
3
Location
Michigan
#3
Right away my dash was wonky. It was at dealership for 28 days while they decided what to do. Software reset didn’t work, Ford engineers decided to replace my entire electronic dash. So far, 2 weeks, no more issues. Although steering wheel backlights still need fixed.
 
Messages
128
Reactions
39
Location
Cincinnati, OH
#4
Right away my dash was wonky. It was at dealership for 28 days while they decided what to do. Software reset didn’t work, Ford engineers decided to replace my entire electronic dash. So far, 2 weeks, no more issues. Although steering wheel backlights still need fixed.
Thanks for the info @Jules, can you share the repair invoice? Curious to see which parts they replace. Also did Ford provide you with a loaner during the repair?
 

Jules

New Member
Messages
12
Reactions
3
Location
Michigan
#5
Thanks for the info @Jules, can you share the repair invoice? Curious to see which parts they replace. Also did Ford provide you with a loaner during the repair?
I have not seen the invoice yet as it’s still open due to bumper cover not here yet. I’ll see if I can get a copy earlier.
Absolutely I had a vehicle to drive. Edge, then a Fusion and finally an Explorer Limited. I kept putting too many miles on them and had to swap out. Dealership just assigned more (6?) Explorers in the loaner fleet due to high number of Explorers in for service.
 

Jules

New Member
Messages
12
Reactions
3
Location
Michigan
#6
Oh ya, vehicle had 3 spots of damage from transport. 2 were buffed out but bumper cover had gouges and needs to be replaced. Ticked me off, dealership let me leave the lot without mentioning it. I was back the next morning to get it ordered.
 
Messages
128
Reactions
39
Location
Cincinnati, OH
#7
Oh ya, vehicle had 3 spots of damage from transport. 2 were buffed out but bumper cover had gouges and needs to be replaced. Ticked me off, dealership let me leave the lot without mentioning it. I was back the next morning to get it ordered.
Glad they took care of it. On my last two vehicle purchases I film every inch of the car with my phone before signing any paperwork. Lots of times you can always go back and check the video and find things that you missed during the initial inspection. Either way congrats!
 

Jules

New Member
Messages
12
Reactions
3
Location
Michigan
#8
I received the confusing repair order today.
The parts listed on the repair order are Camera (LB5Z-19G490-A) and Instrum (LB5Z-10849-GZ)
I see in the narrative where they tested many things, and replaced a module and camera. I was told they ordered a instrument panel (screen) but do not see in the narrative it was replaced.
I'm going to bring this back to the service department and figure out what they actually did..............
 
Messages
29
Reactions
7
Location
Houston, TX, USA
#10
Glad they took care of it. On my last two vehicle purchases I film every inch of the car with my phone before signing any paperwork. Lots of times you can always go back and check the video and find things that you missed during the initial inspection. Either way congrats!
Great idea! Wish I had done this before signing. So far all is good though.


Sent from my iPhone using Tapatalk
 
Messages
22
Reactions
3
Location
Phoenix, AZ, USA
#11
Right away my dash was wonky. It was at dealership for 28 days while they decided what to do. Software reset didn’t work, Ford engineers decided to replace my entire electronic dash. So far, 2 weeks, no more issues. Although steering wheel backlights still need fixed.
So you are not experiencing any screen lag?
 
Messages
10
Reactions
2
Location
Cincinnati, OH, USA
#12
I was driving and two minutes into my drive, my screen went black. I pulled off. Turned the explorer COMPLETELY off. Waiting a minute.... restarted and it works fine now. Very frustrating though. And CarPlay seems to sometimes connect, sometimes not.
 
Messages
39
Reactions
3
Location
Atlanta, GA, USA
#13
The screen is one thing I havent had issues with. Not sure if it's because I updated via wifi the moment I got home after purchasing. Could be just luck.
 
Messages
109
Reactions
35
Location
North Hampton, NH, USA
#14
We have a bit of screen "Lag". But what is weird is the mirror fold in on exit function seemed to turn itself on. Went into the window to select and shut that option off and the on/off selection will not respond to touch. All else appears to be functional.??
 
Messages
109
Reactions
35
Location
North Hampton, NH, USA
#15
We have a bit of screen "Lag". But what is weird is the mirror fold in on exit function seemed to turn itself on. Went into the window to select and shut that option off and the on/off selection will not respond to touch. All else appears to be functional.??
Ran a wifi update and all is good now.
 

malli

New Member
Messages
1
Reactions
0
Location
NYC, NY, USA
#16
Ive been pretty much dealing with this since the 2nd week i got the car and that was Mid Nov...ford service dept here in nyc doesn't seem to know how to fix it, all they do is keep resetting and telling me there's no update in the system for it
 

Attachments



Top