• Sign Up! To view all forums and unlock additional cool features

    Welcome to the #1 Explorer ST Forum and Explorer ST community dedicated to Explorer ST owners and enthusiasts. Register for an account, it's free and it's easy, so don't hesitate to join the Explorer ST Forum today!

Several warranty issues- have you had the same?

Kaycott88

New Member
Messages
4
Reactions
3
Location
Punta Gorda, FL, USA
#1
I am taking my ST to the dealer tomorrow for several issues to see if anyone else has experienced anything similar:

1. driver side mirror appears double/blurry. headlights of vehicles are blurry even in the day time, meanwhile the passenger is perfectly clear
2. passenger side mirror whistles loudly. cant put my windows down without hearing it. super annoying.
3. passenger side seat cooling function. the butt part blows cool air, back rest area no longer blows cool air
4. "VOL" button on dash light. this light turns off when you dim the whole dash display. all other buttons on the dash stay lit.
5. GPS/nav is off. GPS often gets off track and shows I am driving through bodies of water or through patches of land with no streets (seems like calibration is off). it will happen periodically then return to normal.

Most of these issues I have on video. Looking for any advice/input.
 

Lak

New Member
Messages
9
Reactions
4
Location
Los Angeles
#6
I have high pitched wind noise big time.


Sent from my iPad using Tapatalk
 
Messages
39
Reactions
3
Location
Atlanta, GA, USA
#7
I have high pitched wind noise big time.


Sent from my iPad using Tapatalk
Just picked mines up and wind noise/whistle is so bad. I dont know if I can take it anymore. Just blasting the music up to cover it up.
 
Messages
56
Reactions
22
Location
Albuquerque, NM, USA
#9
First day I started it up I had three warnings.
1. Auto park error
2. Park aid fault
3. Reverse brake assist not available

Also, when I went to pick it up at delivery, the posts for securing the floor mats on the driver's side were missing. The dealer had to order a set, then they'll have to cut up the carpet to install them some time next week.
 
Messages
94
Reactions
34
Location
Vancouver, WA, USA
#10
Heater takes at least 30 minutes of driving to start blowing warm air; never hot, only warm and it intermittently goes back to cold. It’s going in on Tuesday (2nd time for this, first time they said it’s normal). It most likely has something to do with the climate control sensors but I hope they don’t have to tear the dash apart to fix this.
 
Messages
56
Reactions
22
Location
Albuquerque, NM, USA
#11
First day I started it up I had three warnings.
1. Auto park error
2. Park aid fault
3. Reverse brake assist not available

Also, when I went to pick it up at delivery, the posts for securing the floor mats on the driver's side were missing. The dealer had to order a set, then they'll have to cut up the carpet to install them some time next week.
Vehicle has been at the dealer since last Thursday, so a week tomorrow.

They determined one of the parking sensors in the bumper was bad. They had to remove the rear bumper and then paint the new part to match, then reinstall the bumper. Problem is they were sent (or more likely ordered) the wrong part. Supposedly it’ll be delivered tomorrow, then in paint, then reinstalled, then ready for pickup on Friday.

To add insult to injury, they gave us a base model Escape as a loaner vehicle...
 

Mark S.

New Member
Messages
15
Reactions
0
Location
Evergreen Park, IL, USA
#12
I am taking my ST to the dealer tomorrow for several issues to see if anyone else has experienced anything similar:

1. driver side mirror appears double/blurry. headlights of vehicles are blurry even in the day time, meanwhile the passenger is perfectly clear
2. passenger side mirror whistles loudly. cant put my windows down without hearing it. super annoying.
3. passenger side seat cooling function. the butt part blows cool air, back rest area no longer blows cool air
4. "VOL" button on dash light. this light turns off when you dim the whole dash display. all other buttons on the dash stay lit.
5. GPS/nav is off. GPS often gets off track and shows I am driving through bodies of water or through patches of land with no streets (seems like calibration is off). it will happen periodically then return to normal.

Most of these issues I have on video. Looking for any advice/input.
Vehicle has been at the dealer since last Thursday, so a week tomorrow.

They determined one of the parking sensors in the bumper was bad. They had to remove the rear bumper and then paint the new part to match, then reinstall the bumper. Problem is they were sent (or more likely ordered) the wrong part. Supposedly it’ll be delivered tomorrow, then in paint, then reinstalled, then ready for pickup on Friday.

To add insult to injury, they gave us a base model Escape as a loaner vehicle...
I am taking my ST to the dealer tomorrow for several issues to see if anyone else has experienced anything similar:

1. driver side mirror appears double/blurry. headlights of vehicles are blurry even in the day time, meanwhile the passenger is perfectly clear
2. passenger side mirror whistles loudly. cant put my windows down without hearing it. super annoying.
3. passenger side seat cooling function. the butt part blows cool air, back rest area no longer blows cool air
4. "VOL" button on dash light. this light turns off when you dim the whole dash display. all other buttons on the dash stay lit.
5. GPS/nav is off. GPS often gets off track and shows I am driving through bodies of water or through patches of land with no streets (seems like calibration is off). it will happen periodically then return to normal.

Check engine light came on, on way home from dealer. Not even 10 miles after my purchase. Called dealer next day said to bring it in will check it out. Brought it in they cleared the code said probably something from the factory. Came back on later that day. Back in the shop now. They don't know what is wrong could be something in the wiring they said they will probably have to call Ford engineering. Not sounding very promising. To add insult to injury they gave me a Ford Ecos for a loaner spent $60,000.00 on a Explore and they give me a $25,000.00 loaner. Brought my 3 year old Chevy van in for work and they gave me a brand new Silverado for a loaner. Been a GM man my whole life Ford is not making me a happy person.
 
Messages
56
Reactions
22
Location
Albuquerque, NM, USA
#14
Vehicle went back to the dealer last Thursday, so almost 2 weeks in service during the first four weeks we’ve owned it. They said it would be ready yesterday, but no one called. Calling this morning for an update.

Same issues as last time:
1. Auto park error
2. Park aid fault
3. Reverse brake assist not available

One new issue that came up since delivery - the cargo area light does not work. They told me it was a bad LED bulb, but once it was replaced, the light still does not work. They said they would diagnose the issue and fix it.

They did finally install the driver’s side floor mat posts, so that’s one thing to check off the list...
 
Messages
56
Reactions
22
Location
Albuquerque, NM, USA
#15
Finally picked up the vehicle from the dealer yesterday after being there a week, and while on a food run at 7:00pm I was pulling into the restaurant parking lot, then a whole litany of alerts popped up.

Here they are in order:
1. Service AdvanceTrac
2. 4WD Fault Service Required
3. Auto Hold System Fault
4. Pre-Collision Assist Not Available
5. Reverse Brake Assist Not Available Set Manual
6. Drive Mode Not Available
7. For Hill Descent Select Gear

It would not switch out of hill descent mode and low gear, so I drove it home at a crawl. Called the service department and we’re going to bring it back in Monday for more troubleshooting.

The dealer has suggested a willingness to discuss getting us into a different vehicle, which is encouraging considering the issues we have been having since the first week in January.
 
Last edited:
Messages
56
Reactions
22
Location
Albuquerque, NM, USA
#16
Got approved from the dealer for the buyback, and am now in the process of contacting Ford Customer Service to initiate on their end.

On another note, Ford is paying our first month's car payment, as it's been in the service department for over four weeks out of the eight we have owned it.
 
Messages
41
Reactions
13
Location
Minneapolis, MN, USA
#18
Seven and a half weeks at the dealer and still no buyback.
I requested my buyback last week - Monday or Tuesday - direct through Ford and received my approval yesterday. I'll give them credit for responding quickly as I launched the escalation through Facebook Messenger. Still don't know what my options are but I was pretty surprised it went that quickly and I never used anyone at my selling or servicing dealer.
 


Top