• Sign Up! To view all forums and unlock additional cool features

    Welcome to the #1 Explorer ST Forum and Explorer ST community dedicated to Explorer ST owners and enthusiasts. Register for an account, it's free and it's easy, so don't hesitate to join the Explorer ST Forum today!

Leak under front of vehicle, passenger side

ExpST2020

New Member
Messages
2
Reactions
2
Location
NJ
#1
Three days after purchasing my ST I noticed a puddle under the passenger side front. At first it appeared to be antifreeze due to the color. I called the dealership and brought the vehicle in for service to take a look. After a pressure test and checking other possibilities, nothing could be found. Over the weekend I placed some paper on the ground and more fluid had dripped out. After checking under the SUV, I was able to locate the source and drove back to the dealership. The leak is coming from the aluminum pipe at the bottom of the A/C unit. Apparently Ford changed the color of antifreeze so it looks like the same color of the freon. Both fluids have a yellow color. The mechanic also said, the new antifreeze doesn't feel oily compared to the freon that feels very oily. Now I'm waiting on a part to come in to hopefully correct the issue.
 

ExpST2020

New Member
Messages
2
Reactions
2
Location
NJ
#3
Update on the leak: I brought my Explorer back to the dealer this week to have the repair completed. The first issue was when service ordered the part, the wrong part came in. I was told the part number ordered was correct, however it was not for a 2020 Explorer. Two days later, I learned that the part needed was on emergency back order. My brand new SUV was at my dealership for 5 days before a part was finally located to make the repair. The TXV line was leaking at the joint and the repair was to the TXV line from the evaporator core. They performed a vacuum test on the AC system and had to add 13.4 ounces of freon to replace what had leaked out. The AC is now blowing cold air!

My wife had read some articles about AC problems with the new Explorers on several other sites. I'm wondering if those other issues are due this defect.
 


Top