• Sign Up! To view all forums and unlock additional cool features

    Welcome to the #1 Explorer ST Forum and Explorer ST community dedicated to Explorer ST owners and enthusiasts. Register for an account, it's free and it's easy, so don't hesitate to join the Explorer ST Forum today!

Blind Spot and Cross Traffic system stopped working

Messages
234
Reactions
170
Points
37
Location
Punta Gorda, FL, USA
#1
Has anybody had any issues with the Bliss system?
 

Messages
39
Reactions
24
Points
2
Location
Oconomowoc, WI, USA
#2
Yes. Goes into the dealer tomorrow. On mine, it seems like a sensor that works intermittently.
 

OP
STJIM
Messages
234
Reactions
170
Points
37
Location
Punta Gorda, FL, USA
Thread Starter #4
Yes. Goes into the dealer tomorrow. On mine, it seems like a sensor that works intermittently.
We are in on Tues morn. Will post when I hear what they have to say. Jim
 

OP
STJIM
Messages
234
Reactions
170
Points
37
Location
Punta Gorda, FL, USA
Thread Starter #5
Yes. Goes into the dealer tomorrow. On mine, it seems like a sensor that works intermittently.
Road Racer, if you get your vehicle back tomorrow would yo post what your dealer finds. Maybe I’ll have some ammunition for Tuesday. Thanks! Jim
 

Messages
39
Reactions
24
Points
2
Location
Oconomowoc, WI, USA
#6
Side object detection control module, and no they didn’t have it in stock, and don’t know when they can get one.
 

OP
STJIM
Messages
234
Reactions
170
Points
37
Location
Punta Gorda, FL, USA
Thread Starter #7
Side object detection control module, and no they didn’t have it in stock, and don’t know when they can get one.
Crap! Dropped ours off this afternoon. A day early. Will post soon as I get it back. Can’t imagine them having parts either. Thanks! Jim
 

OP
STJIM
Messages
234
Reactions
170
Points
37
Location
Punta Gorda, FL, USA
Thread Starter #8
Crap! Dropped ours off this afternoon. A day early. Will post soon as I get it back. Can’t imagine them having parts either. Thanks! Jim
Same module problem. Same answer they don’t have one and don’t have a clue when they will be able to get one.
I’m sure glad I like this thing so much!!
Jim
 

My ST is Better!

Member
U.S. Army Veteran
Messages
101
Reactions
59
Points
27
Location
Chicago, IL, USA
#9
Same here they had my truck for two days, and had no clue what it was, I went and got my truck and told them I'll be back when I'm on vacation!!
 

Messages
39
Reactions
24
Points
2
Location
Oconomowoc, WI, USA
#10
Received notice from the dealer that the new module has arrived, take it in next week for replacement
 

OP
STJIM
Messages
234
Reactions
170
Points
37
Location
Punta Gorda, FL, USA
Thread Starter #11
Lucky you! Talked to Ford and my dealer today. Refused to give me a clue when. Glad someone is getting taken care of. I was actually out looking at new cars yesterday. Congrats!
 

OP
STJIM
Messages
234
Reactions
170
Points
37
Location
Punta Gorda, FL, USA
Thread Starter #12
Received notice from the dealer that the new module has arrived, take it in next week for replacement

would you mind telling me who your dealer is? Thanks. Jim
 

GTP

Member
Messages
79
Reactions
62
Points
17
Location
Indy
#15
Ours became intermittent last week just as we started on vacation for ST Experience day. It is now a permanent failure. Just returned from dealer, who ordered a module, and Yes he said they are back-ordered, and No he doesn't know for how long.

We are at about 2500 miles on the odo.
 

Messages
39
Reactions
24
Points
2
Location
Oconomowoc, WI, USA
#16
They replaced the module today, and it seems to be working. Unrelated, WiFI in the car doesn’t connect to the Internet, dealer just ordered a telematics control unit (TCU). All other cell related features work fine, just not the in car WiFi.
 

OP
STJIM
Messages
234
Reactions
170
Points
37
Location
Punta Gorda, FL, USA
Thread Starter #17
They replaced the module today, and it seems to be working. Unrelated, WiFI in the car doesn’t connect to the Internet, dealer just ordered a telematics control unit (TCU). All other cell related features work fine, just not the in car WiFi.
Thanks for the update! I still haven’t heard a word on my module. Like they said earlier, they couldn’t tell me if they could fix it by the end of the year. Not a joke! One more time, I’m sure glad I like this vehicle. Happy you got yours handled! Jim
 

GTP

Member
Messages
79
Reactions
62
Points
17
Location
Indy
#18
Ours was fixed yesterday. Only one week from diagnosis to repair, so not bad for us.

We had become rather spoiled on all the "radar-related" features, and then it failed by halfway through vacation.

Here is the repair ticket.

SODL_repair_20200819.jpg
 

OP
STJIM
Messages
234
Reactions
170
Points
37
Location
Punta Gorda, FL, USA
Thread Starter #19
GTP, thanks! Can’t wait to send this to my dealer! Jim
 



Top